re = /PosService\s+AddInfo:(?<info_code>.+)/m
str = '[Information] PosService AddInfo:[5006] - Stop customer'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end