// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)PosService\s+AddInfo:(?<info_code>.+)").unwrap();
let string = "[Information] PosService AddInfo:[5006] - Stop customer";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}