$re = '/PosService\s+AddInfo:(?<info_code>.+)/m';
$str = '[Information] PosService AddInfo:[5006] - Stop customer';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);