package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)PosService\s+AddInfo:(?<info_code>.+)`)
var str = `[Information] PosService AddInfo:[5006] - Stop customer`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}