# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\d\K\s+(\d)/$1/g;t' <<< "old iccid : 809831 3245 345 new iccid : 999000 112221"