import re
regex = re.compile(r"\d\K\s+(\d)")
test_str = "old iccid : 809831 3245 345 new iccid : 999000 112221"
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)