re = /\d\K\s+(\d)/
str = 'old iccid : 809831 3245 345 new iccid : 999000 112221'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result