#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<!\S)\d+(?:/\d+)?\s[A-Za-z].*?(?=\s+\d+\b|$)"
Local $sString = "17 Howard Rd Howard. Stdnt 11/169 Wall Road, Wontown, Wkr 105 AGNEW, Marilyn Barbara 106 AGNEW, Mavis Rosina"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")