import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\S)\\d+(?:/\\d+)?\\s[A-Za-z].*?(?=\\s+\\d+\\b|$)";
final String string = "17 Howard Rd Howard. Stdnt 11/169 Wall Road, Wontown, Wkr 105 AGNEW, Marilyn Barbara 106 AGNEW, Mavis Rosina";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}