using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\S)\d+(?:/\d+)?\s[A-Za-z].*?(?=\s+\d+\b|$)";
string input = @"17 Howard Rd Howard. Stdnt 11/169 Wall Road, Wontown, Wkr 105 AGNEW, Marilyn Barbara 106 AGNEW, Mavis Rosina";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}