const regex = new RegExp('(?<!\\S)\\d+(?:/\\d+)?\\s[A-Za-z].*?(?=\\s+\\d+\\b|$)', 'gm')
const str = `17 Howard Rd Howard. Stdnt 11/169 Wall Road, Wontown, Wkr 105 AGNEW, Marilyn Barbara 106 AGNEW, Mavis Rosina`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}