const regex = /('''|"""|["'])((?:\\.|.)*?)\1/gms;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\'\'\'|"""|["\'])((?:\\\\.|.)*?)\\1', 'gms')
const str = `print("This is also an NL test")
variable = "!\\n"
print('And this has an escaped quote "don\\'t" in it ', variable,
"This has a single quote ' but doesn\\'t end the quote as it" + \\
" started with double quotes")
if "Foo Bar" != '''Another Value''':
"""
This is just nonsense
"""
aux = '?'
print("Did I \\"failed\\"?", f"{aux}")`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}