use strict;
my $str = 'print("This is also an NL test")
variable = "!\\n"
print(\'And this has an escaped quote "don\\\'t" in it \', variable,
"This has a single quote \' but doesn\\\'t end the quote as it" + \\
" started with double quotes")
if "Foo Bar" != \'\'\'Another Value\'\'\':
"""
This is just nonsense
"""
aux = \'?\'
print("Did I \\"failed\\"?", f"{aux}")';
my $regex = qr/('''|"""|["'])((?:\\.|.)*?)\1/msp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}