$re = '/(\'\'\'|"""|["\'])((?:\\\\.|.)*?)\1/ms';
$str = 'print("This is also an NL test")
variable = "!\\n"
print(\'And this has an escaped quote "don\\\'t" in it \', variable,
"This has a single quote \' but doesn\\\'t end the quote as it" + \\
" started with double quotes")
if "Foo Bar" != \'\'\'Another Value\'\'\':
"""
This is just nonsense
"""
aux = \'?\'
print("Did I \\"failed\\"?", f"{aux}")';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);