re = /('''|"""|["'])((?:\\.|.)*?)\1/m
str = 'print("This is also an NL test")
variable = "!\\n"
print(\'And this has an escaped quote "don\\\'t" in it \', variable,
"This has a single quote \' but doesn\\\'t end the quote as it" + \\
" started with double quotes")
if "Foo Bar" != \'\'\'Another Value\'\'\':
"""
This is just nonsense
"""
aux = \'?\'
print("Did I \\"failed\\"?", f"{aux}")'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end