# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/'\/".*?"', '"COM99"'/$1=/gm;t' <<< "$my name is $your name is"