re = /'\/".*?"', '"COM99"'/m
str = '$my name is $your name is'
subst = '$1='
result = str.gsub(re, subst)
# Print the result of the substitution
puts result