$re = '/\'/".*?"\', \'"COM99"\'/m';
$str = '$my name is $your name is';
$subst = "$1=";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;