use strict;
my $str = '$my name is $your name is';
my $regex = qr/'/".*?"', '"COM99"'/mp;
my $subst = '$1=';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";