using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<date>\d{4}-\d{2}-\d{2}) (?<time>\d{2}_\d{2}_\d{2})(-| - )(?<window>.*?)(?<extension>\.(png|jpg|jpeg))";
string input = @"2017-08-31 18_57_42-HandBrake.png
2017-08-31 18_57_43-HandBrake.png
2017-08-31 18_57_42-HandBrake - Kopie.png
2017-08-31 18_57_42-HandBrake2.png
2019-03-09 11_11_09 - musicBee - 000003.png
should fail.png'";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}