const regex = /(?<date>\d{4}-\d{2}-\d{2}) (?<time>\d{2}_\d{2}_\d{2})(-| - )(?<window>.*?)(?<extension>\.(png|jpg|jpeg))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<date>\\d{4}-\\d{2}-\\d{2}) (?<time>\\d{2}_\\d{2}_\\d{2})(-| - )(?<window>.*?)(?<extension>\\.(png|jpg|jpeg))', 'g')
const str = `2017-08-31 18_57_42-HandBrake.png
2017-08-31 18_57_43-HandBrake.png
2017-08-31 18_57_42-HandBrake - Kopie.png
2017-08-31 18_57_42-HandBrake2.png
2019-03-09 11_11_09 - musicBee - 000003.png
should fail.png'`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}