package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?<date>\d{4}-\d{2}-\d{2}) (?<time>\d{2}_\d{2}_\d{2})(-| - )(?<window>.*?)(?<extension>\.(png|jpg|jpeg))`)
var str = `2017-08-31 18_57_42-HandBrake.png
2017-08-31 18_57_43-HandBrake.png
2017-08-31 18_57_42-HandBrake - Kopie.png
2017-08-31 18_57_42-HandBrake2.png
2019-03-09 11_11_09 - musicBee - 000003.png
should fail.png'`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}