import re
regex = re.compile(r"(?<date>\d{4}-\d{2}-\d{2}) (?<time>\d{2}_\d{2}_\d{2})(-| - )(?<window>.*?)(?<extension>\.(png|jpg|jpeg))")
test_str = ("2017-08-31 18_57_42-HandBrake.png\n"
"2017-08-31 18_57_43-HandBrake.png\n"
"2017-08-31 18_57_42-HandBrake - Kopie.png\n"
"2017-08-31 18_57_42-HandBrake2.png\n"
"2019-03-09 11_11_09 - musicBee - 000003.png\n"
"should fail.png'")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")