using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\G[^""]*?\K(?:\s*!\s*(?=[""(]))([^""!]*(?:""[^""]*"")?)";
string substitution = @" ! \1";
string input = @"( ! ""A"" ! (!""B"" ""C"" "" ! ( ""))
";
RegexOptions options = RegexOptions.Singleline | RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}