const regex = /\G[^"]*?\K(?:\s*!\s*(?=["(]))([^"!]*(?:"[^"]*")?)/gsm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\G[^"]*?\\K(?:\\s*!\\s*(?=["(]))([^"!]*(?:"[^"]*")?)', 'gsm')
const str = `( ! "A" ! (!"B" "C" " ! ( "))
`;
const subst = ` ! \1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);