$re = '/\G[^"]*?\K(?:\s*!\s*(?=["(]))([^"!]*(?:"[^"]*")?)/sm';
$str = '( ! "A" ! (!"B" "C" " ! ( "))
';
$subst = " ! \1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;