import Foundation
let pattern = #"\G[^"]*?\K(?:\s*!\s*(?=["(]))([^"!]*(?:"[^"]*")?)"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .dotMatchesLineSeparators])
let testString = #"""
( ! "A" ! (!"B" "C" " ! ( "))
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #" ! \1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)