re = /\G[^"]*?\K(?:\s*!\s*(?=["(]))([^"!]*(?:"[^"]*")?)/m
str = '( ! "A" ! (!"B" "C" " ! ( "))
'
subst = ' ! \\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result