using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<<<([A-Za-z_]\w*)(?:\R(?!\1;\R).*)*\R(?:\R(?!\1;\R).*)*\R\1;\R";
string input = @"<<<([A-Z]+)\n.*\n\n.*\n *\1\b
This works if there is only one HEREDOC of that type in the file, but if there were more than one it'll look at the code between the HEREDOCs.
<<<([A-Z]+)\n(?!.*\1.*).*\n\n(?!.*\1.*).*\n *\1\b
With negative lookaheads should then work... but it doesn't match at all :-(
I think I can't use negative look-behinds cause it would not contain a fixed length.
$out .= <<<HTML
aaaaa
aaaaa
bbbbb
HTML;
// Shouldn't match, cause the empty line is outside the HEREDOC
$out .= <<<HTML
aaaaa
aaaaa
bbbbb
HTML;
$out .= <<<HTML
Should match, cause it has a empty line in the HEREDOC
aaaaa
bbbbb
HTML;
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}