# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<<<([A-Za-z_]\w*)(?:\R(?!\1;\R).*)*\R(?:\R(?!\1;\R).*)*\R\1;\R"
test_str = ("<<<([A-Z]+)\\n.*\\n\\n.*\\n *\\1\\b\n"
"This works if there is only one HEREDOC of that type in the file, but if there were more than one it'll look at the code between the HEREDOCs.\n\n"
"<<<([A-Z]+)\\n(?!.*\\1.*).*\\n\\n(?!.*\\1.*).*\\n *\\1\\b\n"
"With negative lookaheads should then work... but it doesn't match at all :-(\n\n"
"I think I can't use negative look-behinds cause it would not contain a fixed length.\n\n\n"
"$out .= <<<HTML\n"
" aaaaa\n"
" aaaaa\n"
" bbbbb\n"
"HTML;\n"
"// Shouldn't match, cause the empty line is outside the HEREDOC\n"
"$out .= <<<HTML\n"
" aaaaa\n"
" aaaaa\n"
" bbbbb\n"
"HTML;\n\n"
"$out .= <<<HTML\n"
" Should match, cause it has a empty line in the HEREDOC\n"
" aaaaa\n\n"
" bbbbb\n"
"HTML;\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.