const regex = /<<<([A-Za-z_]\w*)(?:\R(?!\1;\R).*)*\R(?:\R(?!\1;\R).*)*\R\1;\R/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<<<([A-Za-z_]\\w*)(?:\\R(?!\\1;\\R).*)*\\R(?:\\R(?!\\1;\\R).*)*\\R\\1;\\R', 'gm')
const str = `<<<([A-Z]+)\\n.*\\n\\n.*\\n *\\1\\b
This works if there is only one HEREDOC of that type in the file, but if there were more than one it'll look at the code between the HEREDOCs.
<<<([A-Z]+)\\n(?!.*\\1.*).*\\n\\n(?!.*\\1.*).*\\n *\\1\\b
With negative lookaheads should then work... but it doesn't match at all :-(
I think I can't use negative look-behinds cause it would not contain a fixed length.
\$out .= <<<HTML
aaaaa
aaaaa
bbbbb
HTML;
// Shouldn't match, cause the empty line is outside the HEREDOC
\$out .= <<<HTML
aaaaa
aaaaa
bbbbb
HTML;
\$out .= <<<HTML
Should match, cause it has a empty line in the HEREDOC
aaaaa
bbbbb
HTML;
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}