use strict;
my $str = '<<<([A-Z]+)\\n.*\\n\\n.*\\n *\\1\\b
This works if there is only one HEREDOC of that type in the file, but if there were more than one it\'ll look at the code between the HEREDOCs.
<<<([A-Z]+)\\n(?!.*\\1.*).*\\n\\n(?!.*\\1.*).*\\n *\\1\\b
With negative lookaheads should then work... but it doesn\'t match at all :-(
I think I can\'t use negative look-behinds cause it would not contain a fixed length.
$out .= <<<HTML
aaaaa
aaaaa
bbbbb
HTML;
// Shouldn\'t match, cause the empty line is outside the HEREDOC
$out .= <<<HTML
aaaaa
aaaaa
bbbbb
HTML;
$out .= <<<HTML
Should match, cause it has a empty line in the HEREDOC
aaaaa
bbbbb
HTML;
';
my $regex = qr/<<<([A-Za-z_]\w*)(?:\R(?!\1;\R).*)*\R(?:\R(?!\1;\R).*)*\R\1;\R/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}