import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<<<([A-Za-z_]\\w*)(?:\\R(?!\\1;\\R).*)*\\R(?:\\R(?!\\1;\\R).*)*\\R\\1;\\R";
final String string = "<<<([A-Z]+)\\n.*\\n\\n.*\\n *\\1\\b\n"
+ "This works if there is only one HEREDOC of that type in the file, but if there were more than one it'll look at the code between the HEREDOCs.\n\n"
+ "<<<([A-Z]+)\\n(?!.*\\1.*).*\\n\\n(?!.*\\1.*).*\\n *\\1\\b\n"
+ "With negative lookaheads should then work... but it doesn't match at all :-(\n\n"
+ "I think I can't use negative look-behinds cause it would not contain a fixed length.\n\n\n"
+ "$out .= <<<HTML\n"
+ " aaaaa\n"
+ " aaaaa\n"
+ " bbbbb\n"
+ "HTML;\n"
+ "// Shouldn't match, cause the empty line is outside the HEREDOC\n"
+ "$out .= <<<HTML\n"
+ " aaaaa\n"
+ " aaaaa\n"
+ " bbbbb\n"
+ "HTML;\n\n"
+ "$out .= <<<HTML\n"
+ " Should match, cause it has a empty line in the HEREDOC\n"
+ " aaaaa\n\n"
+ " bbbbb\n"
+ "HTML;\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}