import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "AS \"(.+)\\.(.+)\"";
final String string = " table1.field1 AS \"table1.field1\",\n"
+ " table2.field2 AS \"table2.field2\",\n"
+ " table3.field3 AS \"table3.field3\",\n"
+ " table4.field1 AS \"table4.field1\",\n"
+ " table4.field1 AS \"table5.field5\",\n"
+ " table6.field6 AS \"table6.field1\",";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}