package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d+(-\d+)?$`)
var str = `01
02
03
04
05
101-1
101-2
101-3
Name1
Name2
Name3
Name4`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}