const regex = /^\d+(-\d+)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\d+(-\\d+)?$', 'gm')
const str = `01
02
03
04
05
101-1
101-2
101-3
Name1
Name2
Name3
Name4`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}