re = /^\d+(-\d+)?$/m
str = '01
02
03
04
05
101-1
101-2
101-3
Name1
Name2
Name3
Name4'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end