$re = '/^\d+(-\d+)?$/m';
$str = '01
02
03
04
05
101-1
101-2
101-3
Name1
Name2
Name3
Name4';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);