using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s{2,}";
string substitution = @" ";
string input = @"Some value here.";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}