$re = '/^.[^,]*(?=(\,))/';
$str = 'C:\\Program Files\\EnCase21\\Lib\\Mobile\\EnCaseMobileInstaller.msi, 9092, (NULL), (NULL), (NULL), (NULL)
C:\\Program Files\\EnCase21\\Lib\\Mobile\\EnCaseMobileInstaller.msi
EnCaseMobileInstaller.msi
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);