# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([^.\s])\r?\n/$1 /gm;t' <<< "This
is
paragraph
one.
This
is
paragraph
two."