using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([^.\s])\r?\n";
string substitution = @"$1 ";
string input = @"This
is
paragraph
one.
This
is
paragraph
two.";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}