const regex = /([^.\s])\r?\n/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([^.\\s])\\r?\\n', 'gm')
const str = `This
is
paragraph
one.
This
is
paragraph
two.`;
const subst = `$1 `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);