use strict;
my $str = 'This
is
paragraph
one.
This
is
paragraph
two.';
my $regex = qr/([^.\s])\r?\n/mp;
my $subst = '$1 ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";