$re = '/([^.\s])\r?\n/m';
$str = 'This
is
paragraph
one.
This
is
paragraph
two.';
$subst = "$1 ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;