# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(.+)?(..)/$1/gm;t' <<< "782A3
0012122
76542A
333333CD"