use strict;
my $str = '782A3
0012122
76542A
333333CD';
my $regex = qr/(.+)?(..)/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";