$re = '/(.+)?(..)/m';
$str = '782A3
0012122
76542A
333333CD';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;