package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(.+)?(..)`)
var str = `782A3
0012122
76542A
333333CD`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}