#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(.+)?(..)"
Local $sString = "782A3" & @CRLF & _
"0012122" & @CRLF & _
"76542A" & @CRLF & _
"333333CD"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)